CPIK Libraries

This section is for developers looking for technical information on how to integrate with CoPilot Integration Kit (CPIK) libraries. It explains how to set up the sample application, import the CoPilot Navigation library into your project, and interact with the APIs.

  • The CoPilot navigation library requires Android 4.1, iOS 8, or more current versions.
  • Following the first install of CoPilot, we recommended you restart the application once the licensing and map data have been processed. This is best practice and ensures full CoPilot functionality is available following the initial install.
  • A Xamarin interface is available for Android and iOS. This interface results in all Android and iOS compatible APIs being supported within Xamarin. It has not been noted on individual APIs within the documentation that they are compatible on Xamarin as it is always true, unless stated otherwise.
  • Starting with CoPilot 10.14, we introduced a new CPIK libraries react native module, which allows you integrate CoPilot with applications written in JavaScript.
Last updated July 20, 2021.